Support

Support is part of Event Gallery Extended.

Please get a subscription if you need support. Feel free to use the ticket system or the contact form for reporting defects or pre-sale questions. Make sure you're logged in in order to be able to create a new ticket.

For general information you can also jump to the manual.

Subscribe now!

#3606 – The image could not be loaded

Posted in ‘Event Gallery - General’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Monday, 08 July 2019 11:25 UTC
bmt3000
I am using Event Gallery to display yhe photos archives of our league. Everything was working fine, and I was able to upload hundreds of jpg files inthe correct events and categories.

Since Saturday, I have an issue with the latest Event I added : pictures are not showing in the frontend, I only get the "image could not load" error message.

In the backend, pictures are not showing either. Those pictures are all of a small size, withe simple file name.

Please take a look at the URL posted inm the current thread. The problem is with the last event added, on the right-bottom part of the screen.

Any clues ?

Regards

Bernard

Custom Fields

Event Gallery Version Event Gallery 3.10.22 (build f9c6bc2)
Joomla Version 3.9.8
URL https://www.hydroquilles.net/archives/index.php/photos/speciaux
PHP Version 7.3
 
Monday, 08 July 2019 11:52 UTC
sbluege
Hi,

it seems like the thumbnails can't be writing to the file system. Please make sure your cache folder is writable and there is enough free space.
 
Monday, 08 July 2019 12:00 UTC
bmt3000
Sorry, I can't find that cache folder. Can you please telle me where to find it ?
 
Monday, 08 July 2019 12:09 UTC
sbluege
This is the /cache folder in your main directory.
 
Monday, 08 July 2019 12:21 UTC
bmt3000
in the cashe folder, as described, I have a folder named com/eventgallery et another one named com_eventgallery_images. Both are set to 755 so they should me writable.

I have plenty of space left on the server.
 
Monday, 08 July 2019 12:26 UTC
sbluege
How did you upload those images? Are they readable to the PHP process?
 
Monday, 08 July 2019 12:30 UTC
bmt3000
Images are uploaded from within the component Event Gallery. I've created the Categories, then the Events. Uploads are made from the Event Manager panel
 
Monday, 08 July 2019 12:32 UTC
bmt3000
I've checked the com_eventgallery_images folder, in the cache folder. Images uploaded in the subfolder causing me trouble have a filesize of 0kb, after upload. All images in other subfolders are ok.

Problem is only related to the last created Event
 
Monday, 08 July 2019 12:40 UTC
sbluege
Please delete the empty files. Does this help?

Do you remember what has changed on your server in the meantime?
 
Monday, 08 July 2019 12:49 UTC
bmt3000
I've deleted the empty files and uploaded them again : same result, still 0kb filesize.
Nothing as changed on the server, excepted that I've just renewed the domain name and one-year subscription. Don't know if the host has changed something in the process.

Also, I just realized that I now have another problem : if i try to change anything in the Joomla System Configuration, I get this message : 0 Joomla\Filesystem\File::delete: Failed deleting inaccessible file 14196a96cbe5afb9c66b3d93debe5d77...

Maybe this could be related ?
 
Monday, 08 July 2019 12:57 UTC
sbluege
Maybe. Where do you get this error message? It seems that the PHP user can't access all the files on your server. Maybe your hosting provider changed something?
 
Monday, 08 July 2019 13:09 UTC
bmt3000
I get this error message after clicking on "Save", in the Global System Configuration panel.

Never had this error before. I will submit a support ticket to the host and let you know.

Thanks for your support

B.
 
Monday, 08 July 2019 17:09 UTC
bmt3000
Hosting company told me that nothing has changed on the server. We do more testing and come back to you.

B
 
Tuesday, 09 July 2019 11:38 UTC
bmt3000
Host told me taht no changes were made on the server. This morning, I tried clearing the caches in event Gallery.
It didnt help. The I tried the Sync database option, in event Gallery. (folders first, then files).

Here's the result : https://www.hydroquilles.net/archives/

 
Tuesday, 09 July 2019 14:48 UTC
sbluege
They never do changes :)

But your link is another evidence for my theory. Your http/php-process can't write to the file system. I'm afraid you need to ask the support guys again.

Can you upload files using the Joomla media manager?
 
Friday, 12 July 2019 17:25 UTC
bmt3000
Seems that the problem was on the server. Server was running on php 7.3. I dont know if it was the source of the problem but a lot of things went wrong with that version of php.

I've set back the php version to 7.1 (for now), cleared everything (files and database), reinstalled Joomla 3.9.10, a new database and your component. Everything is now working fine.

Also, the previous installation was running on Gantry5 and Hydrogen template. Now running on stock protostar template. Will try re-installing Gantry5 and Hydrogen, hoping that nothing will screw up again.

It's along process uploading 900 and more pictures...

Thanks for your support

B
 
Friday, 12 July 2019 18:08 UTC
sbluege
You're welcome. The new PHP version can cause trouble. Not because of PHP 7.3, but because of the implementation on that server.