Support

Support is part of Event Gallery Extended.

Please get a subscription if you need support. Feel free to use the ticket system or the contact form for reporting defects or pre-sale questions. Make sure you're logged in in order to be able to create a new ticket.

For general information you can also jump to the manual.

Subscribe now!

#3546 – Images do not show since updated to joomla 3.9.6

Posted in ‘Event Gallery - General’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Thursday, 09 May 2019 14:54 UTC
 Yesterday, I updated Joomla version from 3.9.5 to Joomla 3.9.6. Also updated french language package to latest version.

Nothing else was changed. Today, I've noticed that neither my categories images nor galleries's images are showing.

Files are still on the server, nothing was touched in the backend regarding Event Gallery.

Is there a compatibility problem with Joomla 3.9.6 ? If so, is there an update for Event Gallery for that ?

Regards

B
Custom Fields
Event Gallery Version 3.10.20 (build c4387b2)
Joomla Version 3.9.6
URL http://gestionweb2g2t.ca/joomla/index.php/fr/galeries
PHP Version 7.2.18
 
bmt3000
Thursday, 09 May 2019 15:19 UTC
Hi,

please double check that nothing changed. You're running PHP without the GD extension. Rendering images is not possible without it. Currently, your site shows an error message that imagecreatefromstring is missing.

http://gestionweb2g2t.ca/joomla/index.php/fr/?&mode=crop&width=1280&folder=seascapes&file=dallas_rd_sunse.jpg&option=com_eventgallery&view=resizeimage

Did you clear the cache after installing the Joomla update? That might have revealed an issue with the PHP version you lately switched to.
 
sbluege
Thursday, 09 May 2019 18:34 UTC
Just reverted to PHP 7.0 and images are back. Never saw that error message you shown me.

So the GD library are missing on php 7.2 my host installed lately, right ? So I need to ask my web provider to add it ?

And no, I didn't cleared the cache after upgrading to joomla 3.9.6, I was not aware it was required.

B
 
bmt3000
Friday, 10 May 2019 08:27 UTC
You don't need to clear the cache, I just thought that might have revealed the issue.

I hope your hosting provider can answer the GD question quickly.
 
sbluege